Exchange Hosting error msg

Login or Register to post in the forums

4 posts / 0 new
Last post
vedhapuri
Exchange Hosting error msg
Printer-friendly versionPDF version

 

 i have facing new issue in hosted exchange 2010 sp2 . I have 3 domain controllers 2 servers in windows 2008 and 1 is in windows 2012  whenever run the script to creat new tenent i will get some error in power shell 

 Error msg

 

[PS] E:\Program Files\Microsoft\Exchange Server\V14\Scripts>.\New-Tenant.ps1
 
cmdlet New-Tenant.ps1 at command pipeline position 1
Supply values for the following parameters:
Domain: emkor.local
TenantName: EMK
TenantDomain: EMK.COM
Password: Password@123
Created new organizational unit. [OU=EMK,OU=Hosting]
New-ADGroup : Directory object not found
At E:\Program Files\Microsoft\Exchange Server\V14\Scripts\New-Tenant.ps1:76 char:20
+         New-ADGroup <<<<  -Name "$fGroupName" -sAMAccountName "$fGroupName{$guid}" -Path "OU=$fTenantName,OU=Hosting,
$($objDomain.distinguishedname)" -groupScope universal
    + CategoryInfo          : ObjectNotFound: (CN=Organization...=emkor,DC=local:String) [New-ADGroup], ADIdentityNotF
   oundException
    + FullyQualifiedErrorId : Directory object not found,Microsoft.ActiveDirectory.Management.Commands.NewADGroup
 
Can you give some positive reply...... for this error message..........

 

ingram
ingram's picture
Hi,

Hi,

The New-Tenant script needs to be ran from the Exchange Management Shell, not from PowerShell. You also need to import the activedirectory module by running this command:

Import-Module ActiveDirectory

For those of you curious, vedhapuri is referring to this tutorial on configuring exchange 2010 multi-tenant hosting with service pack 2.

If you have already done that, try running the script in this format to see if it gives the same error:

New-Tenant.ps1 -Domain itswapshop.local -TenantName "ITswapshop INC" -TenantDomain "itswapshop.com" -Password mypassword

vedhapuri
Hi ingram,

Hi ingram,

  I did in Exchangepower shell only with starting Import-module activedirectory command only

 But getting the same error in all exchange servers ie:( mailbox server and cas server )

 By

vedha.k

 

ingram
ingram's picture
Unfortunately this script

Unfortunately this script does not work correctly in environments with multiple domain controllers. You can run each command separately and include "-DomainController <Fqdn>" on each of them. Or it shouldn't be to difficult to modify the script to add that.